pip install 发生错误SSLError There was a problem confirming the ssl certificate解决办法


问题原因:

是因为官方源不再支持TLS1.0和TLS1.1版本,pip之前的版本是使用TLS1.0或TLS1.1,可以重新安装pip来解决
另外一种比较简单的方法也可以完美解决

临时解决:

比如我要安装selenium

pip install selenium -i http://pypi.douban.com/simple --trusted-host pypi.douban.com

永久解决:

修改官方源为豆瓣源并添加信任
在C:\Users\iqiqiya\pip下新建pip.ini文件
内容如下:

[global]

index-url=http://pypi.douban.com/simple

[install]

trusted-host=pypi.douban.com

声明:iqiqiya的博客|版权所有,违者必究|如未注明,均为原创|本网站采用BY-NC-SA协议进行授权

转载:转载请注明原文链接 - pip install 发生错误SSLError There was a problem confirming the ssl certificate解决办法


越努力越幸运!